libncurses.so.5 nicht gefunden

Gespeichert von Erik Wegner am/um Mi, 06.07.2016 - 23:10
Body

Auf einem Archlinux ist bereits ncurses in Version 6 installiert. Allerdings gibt es noch Anwendungen, die auf Version 5 angewiesen sind. Diese Anwendungen quittieren den Dienst mit Meldungen wie:

error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

Beispiele für solche Anwendungen sind:

  • avrdude
  • Android Studio 2.1.2

Dann hilft es, eine symbolische Verknüpfung von der aktuellen Version zur erwarteten Version anzulegen:

sudo ln -s /usr/lib/libncursesw.so.6.0 /usr/lib/libncurses.so.5

Kategorien